Mojave编译安装python3.7.2报错python-zlib错误

一、问题描述:

在编译源码安装python3.7.2过程中报错zipimport.ZipImportError: can't decompress data; zlib not available错误。

二、环境信息

MAC:Mojave 10.14.3

三、解决问题——GOOGLE

https://stackoverflow.com/questions/50036091/pyenv-zlib-error-on-macos

xcode-select --install
sudo installer -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg -target /

根本原因:

xcode-select -v

xcode-select version 2354. 这个版本的xcode-select 似乎在默认情况下不包含Mojave SDK的头文件的,需要手动安装。


评论(0 ) 点赞(13)


暂未登录,请登录之后发表评论。 QQ